Home » Android » android – AVDMANAGER -> Error: Invalid –tag default for the selected package

android – AVDMANAGER -> Error: Invalid –tag default for the selected package

Posted by: admin June 15, 2020 Leave a comment

Questions:
$ avdmanager create avd -n test -k "system-images;android-24;google_apis;x86"

Error: Invalid –tag default for the selected package.

How to solve this error?

How to&Answers:

Use the --abi google_apis/x86 flag.

Answer:

The data store that the sdkmanager v26.1.1 uses is out of date.

Update your tools with:

sdkmanager --update

It will then have the updated tags to choose from. One can also run:

avdmanager -v create avd -g google_apis -n Android-27 -k "system-images;android-27;google_apis;x86"

But always better to run with updated tools.