Home » Android » android – Cannot access zzbql in Firebase

android – Cannot access zzbql in Firebase

Posted by: admin June 15, 2020 Leave a comment

Questions:

When I updated to the latest buildToolsVersion ‘25.0.2’ I got this error when I try to run:

Error:(103, 37) error: cannot access zzbql class file for
com.google.android.gms.internal.zzbql not found

I’m using these Firebase libs:

            compile 'com.google.firebase:firebase-auth:10.0.1'
            compile 'com.google.firebase:firebase-messaging:10.0.1'
            compile 'com.google.firebase:firebase-core:10.0.1'
            compile 'com.google.firebase:firebase-crash:10.0.1'
How to&Answers:

Upgrade your firebase for version 10.2.0

** As of 07.11.2017 it’s 11.6.0

Answer:

The answer to solve the problem really is upgrading Firebase to 10.2.0 as in @DenerRocha ‘s reply.

But you might get the same problem again next time google-play-services is updated. The problem is that the compiler warns you that there’s a new google-play services version, but doesn’t do the same for Firebase. So keep the following in mind:

When you have this:

compile 'com.google.android.gms:play-services-auth:10.2.0'

Your Firebase will be:

compile 'com.google.firebase:firebase-core:10.2.0'
compile 'com.google.firebase:firebase-messaging:10.2.0'
compile 'com.google.firebase:firebase-auth:10.2.0'

When 10.3.0 is release, you’ll have to update all of them to 10.3.0

Answer:

I actually downgraded my compile sdk version ,target sdk version to 26 and associated dependencies as well.
I also downgraded my firebase database and ui dependencies as well to

implementation 'com.google.firebase:firebase-database:11.4.2'
implementation 'com.firebaseui:firebase-ui-auth:3.1.0'

It worked like charm.

Here is my build.gradle(app)

apply plugin: 'com.android.application'
apply plugin: 'com.google.gms.google-services'

android {
compileSdkVersion 26
defaultConfig {
    applicationId "com.e.alcphase222"
    minSdkVersion 21
    targetSdkVersion 26
    versionCode 1
    versionName "1.0"
    testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
}
buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-android-optimize.txt'), 'proguard-rules.pro'
    }
}
}

dependencies {
implementation fileTree(dir: 'libs', include: ['*.jar'])
implementation 'com.android.support:appcompat-v7:26.0.0'
implementation 'com.android.support.constraint:constraint-layout:1.1.3'
implementation 'com.android.support:recyclerview-v7:26.0.0'

implementation 'com.google.firebase:firebase-database:11.4.2'
implementation 'com.firebaseui:firebase-ui-auth:3.1.0'



testImplementation 'junit:junit:4.12'
androidTestImplementation 'com.android.support.test:runner:1.0.2'
androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'

}