Home » Android » android – Error on gradle-2.10-all.zip.lck (The system cannot find the path specified)

android – Error on gradle-2.10-all.zip.lck (The system cannot find the path specified)

Posted by: admin June 15, 2020 Leave a comment

Questions:

I recently updated my Android Studio to the recent version of 2.1.3 and also did some other update that popped up, only to obtain this error below for all my already existing projects on my android studio.

Error:C:\Program Files\Android\Android Studio1\gradle\gradle-2.2.1\wrapper\dists\gradle-2.10-all\a4w5fzrkeut1ox71xslb49gst\gradle-2.10-all.zip.lck (The system cannot find the path specified)

Please Guys I need your assistance. Thanks.

How to&Answers:

Visit https://services.gradle.org/distributions and download the desired gradle version (in your case gradle-2.10-all.zip) and place it in “C:\Users\your_user_name\ .gradle\wrapper\dists\gradle-2.10-all\a4w5fzrkeut1ox71xslb49gst\put_it_here” folder and sync project again.

Answer:

Error:C:\Users\Aman.gradle\caches\3.3\scripts-remapped\build_9xilmbs31p63j7oau8p3qxxmv\d0u1sorhwxy5ca3j4lgnxtkce\cp_proj1efd45104ffa2d33563b85b9edda76e3\cache.properties
(The system cannot find the file specified)

Solution: just go to gradle.wrapper.properties and then,

distributionUrl=https\://services.gradle.org/distributions/gradle-3.4-all.zip

Change in url just increase the gradle version like 2.10 to 2.11 it will work. Then sync the project.

Answer:

The steps given below may solve your problem :

1) Create a new Android project.

2) Then open the build.gradle(Module:app) file(of your new project).

3) copy the dependencies

example :

dependencies {
    compile fileTree(include: ['*.jar'], dir: 'libs')
    compile 'com.android.support:cardview-v7:24.1.1'

    compile 'com.android.support:appcompat-v7:24.1.1'
    compile 'com.android.support:design:24.1.1'
}

4) Add them to your old project which is giving error.

5) Also see the

compileSdkVersion 24
buildToolsVersion "24.0.0"

They should match with what ever is written after v7 support library (android_support_lib_version).

6) Finally sync the project once again.

Answer:

I have similar problem when i was open my previous project. It just download Gradle 3.3 all from Online and after that i found that Error.
In my case I solved that issue just Change

distributionUrl=https://services.gradle.org/distributions/gradle-3.3-all.zip

to

distributionUrl=https://services.gradle.org/distributions/gradle-4.6-all.zip

Because previously I have already downloaded in this Directory since my Android studio was updated to 3.2.1

C:\Users\your_name.gradle\wrapper\dists

Answer:

you should download the appropriate version from https://services.gradle.org/distributions/

and then place the zip file inside c:\users\your name.gradle\wrapper\dists[gradle-v-all\guid] enter image description here

so when you open your android studio starts, it will unzip the zip file. If you try placing the content of the zip file it wont work.