Home » Android » android – Google Play services out of date. Requires 3025100 but found 2012110

android – Google Play services out of date. Requires 3025100 but found 2012110

Posted by: admin May 14, 2020 Leave a comment

Questions:

I’m using the Google maps v2 in my app and am debugging it in the emulator. Since the update on the 26th Feb I now get this error message

Google Play services out of date. Requires 3025100 but found 2012110

I now wonder if anyone has the updated files necessary to run google play services rev 5 in the emulator? I’ve tried to run the app with rev 4 of Google play services, but the emulator is not having it and asks for me to update Google play services. Does anyone have any other ideas perhaps?

Many thanks

How to&Answers:

I found the files I needed in the end, gms and vending

Answer:

After the updateion of ADT 22.0.1 and new Android Private Libraries, the google map service was giving some or the error and app crashes off.
So i found the solution finally and it worked for me.

Just install the google play service lib and than go to the google-play-service/libproject/google-play-services_lib from the link below :-

https://www.dropbox.com/sh/2ok76ep7lmav0qf/9XVlv61D2b

than import that into your workspace .
Clean your project where you want to use gogole-play-services-lib than build it agian and go to the Project > Properties > Java BuildPath > select “Android Private Libraries, android Dependencies, google-play-service”

in Properties itself go to Android and than choose any of the version and than choose add and select google-play-service-lib and than press apply and finally OK.

At last go to the Project > Android Tools > Android Support Libraries . Accept the license and after installing than run your project.

It will Work Fine.

Hope this Will Help You.