Home » Android » android – In project 'app' a resolved Google Play services library dependency depends on another at an exact version

android – In project 'app' a resolved Google Play services library dependency depends on another at an exact version

Posted by: admin April 23, 2020 Leave a comment

Questions:

Trying to create a simple app with FireStore and Google Authentication. Having problem with the gradle:

In project ‘app’ a resolved Google Play services library dependency
depends on another at an exact version (e.g. “[15.0. 1]”, but isn’t
being resolved to that version. Behavior exhibited by the library will
be unknown.

Dependency failing: com.google.android.gms:play-services-flags:15.0.1
-> com.google.android.gms:[email protected][
15.0.1], but play-services-basement version was 16.0.1.

The following dependencies are project dependencies that are direct or
have transitive dependencies that lead to the art ifact with the
issue.
— Project ‘app’ depends onto com.google.firebase:[email protected]
— Project ‘app’ depends onto com.firebaseui:[email protected]

For extended debugging info execute Gradle from the command line with
./gradlew –info :app:assembleDebug to see the dep endency paths to
the artifact. This error message came from the google-services Gradle
plugin, report issues at https://
github.com/google/play-services-plugins and disable by adding
“googleServices { disableVersionCheck = false }” to your b uild.gradle
file.

    apply plugin: 'com.android.application'

    android {
        compileSdkVersion 27
        defaultConfig {
            applicationId "myapp.com"
            minSdkVersion 19
            targetSdkVersion 27
            versionCode 11
            versionName "1.1"
            testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
            multiDexEnabled true
        }
        buildTypes {
            release {
                minifyEnabled false
                proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
            }
        }
    }

    dependencies {
        implementation fileTree(dir: 'libs', include: ['*.jar'])
        implementation 'com.android.support:appcompat-v7:27.1.1'
        implementation 'com.android.support.constraint:constraint-layout:1.1.3'
        testImplementation 'junit:junit:4.12'
        androidTestImplementation 'com.android.support.test:runner:1.0.2'
        androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'
        implementation 'com.google.firebase:firebase-firestore:17.1.5'

        implementation 'com.firebaseui:firebase-ui-auth:4.2.0'

    }

    apply plugin: 'com.google.gms.google-services'
    com.google.gms.googleservices.GoogleServicesPlugin

Project gradle:

buildscript {

    repositories {
        google()
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.2.1'

        classpath 'com.google.gms:google-services:4.2.0'

    }
}

Can somebody help me?

How to&Answers:

The problem was it was missing a dependency.
Adding com.google.firebase:firebase-auth solved the issue.

dependencies {
    implementation fileTree(dir: 'libs', include: ['*.jar'])
    implementation 'com.android.support:appcompat-v7:27.1.1'
    implementation 'com.android.support.constraint:constraint-layout:1.1.3'
    testImplementation 'junit:junit:4.12'
    androidTestImplementation 'com.android.support.test:runner:1.0.2'
    androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'
    implementation 'com.google.firebase:firebase-firestore:17.1.5'

//    implementation'com.google.firebase:firebase-core:16.0.6'
//    implementation'com.google.firebase:firebase-storage:16.0.5'

    implementation'com.google.firebase:firebase-auth:16.1.0' => add this line
    implementation 'com.firebaseui:firebase-ui-auth:4.2.0'
}

Answer:

There’s a known bug with Google Services 4.2.0 that may cause this. Downgrading your google-services version to 4.1.0 in your project’s build.gradle may resolve the issue

buildscript {
    dependencies {
        classpath 'com.google.gms:google-services:4.1.0' //decreased from 4.2.0
    }
}

Answer:

There was a bug related to google-services that was eventually fixed in version 4.3.3.

So you can either use 4.3.3 or the latest version (check here)

classpath 'com.google.gms:google-services:4.3.3' // or latest version

or downgrade to 4.1.0

classpath 'com.google.gms:google-services:4.1.0'

Answer:

i added the latest version of firebase messaging to build.gradle (Module: app) in my project and problem solved

implementation 'com.google.firebase:firebase-messaging:20.0.0'

Answer:

There are many answers here for individual solutions that do not really get down to the problem. Here is how to solve this in general:

As the original log output suggests, it is useful to run the build in the terminal with the following command:

./gradlew --info assembleDebug

This will give you a list of all dependencies that are involved in the conflict. It looks similar to this (I removed the package name stuff to make it a bit more readable):

Dependency Resolution Help: Displaying all currently known paths to any version of the dependency: Artifact(groupId=com.google.firebase, artifactId=firebase-iid)

-- task/module dep -> [email protected]
---- firebase-analytics:17.2.0 library depends -> [email protected]
------ play-services-measurement-api:17.2.0 library depends -> [email protected]

-- task/module dep -> [email protected]
---- firebase-core:17.2.0 library depends -> [email protected]
------ firebase-analytics:17.2.0 library depends -> [email protected]
-------- play-services-measurement-api:17.2.0 library depends -> [email protected]

-- task/module dep -> [email protected]
---- play-services-measurement-api:17.2.0 library depends -> [email protected]

-- task/module dep -> [email protected]

-- task/module dep -> [email protected]
---- firebase-messaging:17.1.0 library depends -> [email protected][16.2.0]

-- task/module dep -> com.pressenger:[email protected]
---- com.pressenger:sdk:4.8.0 library depends -> [email protected]
------ firebase-messaging:17.1.0 library depends -> [email protected][16.2.0]

From this list you get to know 2 things:

  1. Where is the conflicting depedency found
  2. What versions of the conflicting dependency are set up

In my case the conflicting dependency is firebase-iid: It’s either @19.0.0 or @16.2.0

To fix this you must define the top-level dependency of the wrong firebase-iid explicitly in your build.gralde.

So in the upper log you can see that there are 2 examples of an out-dated version of [email protected] One comes from -- task/module dep -> [email protected] the other one from a third-party library (pressenger). We don’t have influence on the third-party library, so nothing to do here.
But for the other dependency, we have to declare it explicitly with the correct version:

implementation 'com.google.firebase:firebase-messaging:20.0.0'

Now the build works again. Happy ending 🙂

Answer:

Your app/build.gradle might have these lemon color blocked on dependencies part in Android Studio like on the picture below,

image

These (lemon color blocks) mean it’s not latest version of dependency. just put mouse on each block, then IDE (Android Studio) tells the numbers that have to be changed.

Answer:

Updating all my Google Play Services libraries to the latest in ALL modules solved the issue for me. I don’t see that you have any Google Play Services libraries, but I wanna leave this answer here to those that might find this useful.

Answer:

My project was working fine (No build issues). All of a sudden, I got this error

“resolved Google Play services library dependency depends on another at an exact version..”

I figured out that it was because I was building offline.

If anyone gets the same error, check if you are building offline.

Answer:

Thanks, but unfortunately, this didn’t entirely work for me. I also had to add the following to my build.grade (Module:app)

implementation 'com.google.android.gms:play-services-flags:16.0.1'
implementation 'com.google.android.gms:play-services-basement:16.0.1'

Answer:

None of the other answers worked for me. My use-case is with React-Native 61+ trying to setup FCM and Analytics. What worked for me was using the latest google-services in android/build.gradle

dependencies {
    classpath "com.android.tools.build:gradle:3.4.2"
    classpath "com.google.gms:google-services:4.3.3" // Need the latest here
}

And then adding the gradle dependencies to android/app/build.gradle required for the products I’m using (in my case Analytics and Cloud Messaging) from here

dependencies {
    ...
    // add the Firebase SDK for Google Analytics
    implementation 'com.google.firebase:firebase-messaging:20.1.0'
    implementation 'com.google.firebase:firebase-analytics:17.2.2'
    ...
}

Answer:

Add FCM to your App added Lower dependency Then I changed the dependency to the latest version this problem has solved.

compile 'com.google.firebase:firebase-messaging:17.3.4'

to

implementation 'com.google.firebase:firebase-messaging:20.0.0'

Answer:

The working solution for me was to remove “firebase-auth” and add “firebase-core” dependency. But after a couple of project rebuilds I started experiencing another compilation issue so I had to add the “firebase-auth” dependency in addition to the “firebase-core” in order to make it work:

implementation 'com.google.firebase:firebase-auth:19.0.0'
implementation 'com.google.firebase:firebase-core:17.0.1'
implementation 'com.firebaseui:firebase-ui-auth:4.3.1'

Answer:

This is new thing happen to me that If your network is not secure and you are getting prompt of Untrusted Certificate.

If you will Accept or Reject, It will give this error until your network will not be secure.

You can work offline by checking Setting -> Gradle -> Offline Mode

Answer:

If you used song haesuk answer, you need to do it for both build.gradle Project (classpath in dependencies), and in build.gradle app (implementations). Also do the same if you change builds for any libraries imported to the app.

I use suggestions provided by android studio and it changed implementations but did not change dependencies hence during build, there was a conflict between the two and it gave me same error.

Answer:

I fixed the problem upgrading this lib in my project’s build.gradle:

classpath 'com.google.gms:google-services:4.3.3'

and these ones in the app module’s build.gradle:

implementation 'com.google.firebase:firebase-core:17.3.0'
implementation 'com.google.firebase:firebase-messaging:20.1.5'

After this, use Android Studio’s Clean menu