Home » Android » android – ShareActionProvider for API level less than 14

android – ShareActionProvider for API level less than 14

Posted by: admin June 15, 2020 Leave a comment

Questions:

is it possible to use shareActionProvider for Apps using API less than 14?

How to&Answers:

It is now possible to do this using the v7 support library.

http://developer.android.com/reference/android/support/v7/widget/ShareActionProvider.html

Answer:

No you can’t use it on pre ICS SDK maybe using v4 support library, see this topic Cross version ShareActionProvider support You can use ActionBarSherlock to support older versions, see this example ShareActionProviders.java

Answer:

In case someone faces frustration in finding what libary to import (not very clear reading off the documentation):

import android.support.v7.widget.ShareActionProvider;

One thing that I guess, gives you a clue is the URL of the docs you are looking at, which I believe corresponds to the API structure:

enter image description here

For myself, this has so far worked for the compatibility-library-related docs.