Home » Android » android – Using version 1.0.0-alpha7 of the constraint library, which is obsolete

android – Using version 1.0.0-alpha7 of the constraint library, which is obsolete

Posted by: admin June 15, 2020 Leave a comment

Questions:

I’m starting using Android Studio 2.2 and trying to play with ConstraintLayout but when I let android studio add it automatically it showed me that error

Using version 1.0.0-alpha7 of the constraint library, which is obsolete

when I try to upgrade it using quick fix I get that error

Error:Could not find com.android.support.constraint:constraint-layout:1.0.0-alpha8.

I think this is a bug in Android Studio. What should I do to fix it?

my current solution is to suppress the error.

How to&Answers:

You need to install ConstraintLayout for Android inside Support Repository package on SDK Tools category of SDK Manager.

Answer:

FileSettingsAppearance & BehaviorSystem SettingsAndroid SDK

Remember choose “show detail”. You should see the latest version of Constraint Layout.
enter image description here

Answer:

You are getting this warning because you are using older version of constraint layout while you have newer version available.
Go to your sdk manager->sdk tools->Support Repository->ConstraintLayout For Android and then tick the Show Package Details checkbox to find the available versions of constraint layout and install the newest version and update your build.gradle(App Level).

Up until now the newest version is constraint-layout:1.0.2 so use this.