Home » Jquery » Bootstrap's JavaScript requires jQuery version 1.9.1 or higher

Bootstrap's JavaScript requires jQuery version 1.9.1 or higher

Posted by: admin November 29, 2017 Leave a comment

Questions:

I have all necessary files in my code and I am still getting this error:

Bootstrap’s JavaScript requires jQuery version 1.9.1 or higher

This is my code:

<script src="http://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js"></script>
<script src='//maxcdn.bootstrapcdn.com/bootstrap/3.3.2/js/bootstrap.min.js'></script>
<script src="js/jquery.responsiveiframe.js"></script>
<script src="js/ios-orientationchange-fix.js"></script>

Anyone got this error before? I could try and download a local copy instead of using the CDN link but it’s really unnecessary, plus i want to know why this isn’t working!

EDIT: I’ve tried many different libraries, the one I posted is the last one I’ve tried

enter image description here

Answers:

Type $.fn.jquery in your console and tell us what numbers it says. You probably have a second version running somewhere.

Questions:
Answers:

Bootstrap v3.3.6 isn’t compatible with the jQuery 3.0. This will be fixed in the upcoming Bootstrap version 3.3.7. Here’s the issue currently open on GitHub. https://github.com/twbs/bootstrap/issues/16834

Questions:
Answers:

In my case(Bootstrap) the issue was, having the JQuery 3.0.0 which is also not fine, So using a version which is an earlier version like 2.2.4.

The Error i got was: Bootstrap’s JavaScript requires jQuery version 1.9.1 or higher, but lower than version 3

Using any of these CDN below as the source would help if this is the case!

jQuery version 2.2.4:

http://ajax.aspnetcdn.com/ajax/jQuery/jquery-2.2.4.js

http://ajax.aspnetcdn.com/ajax/jQuery/jquery-2.2.4.min.js

Hope this helped at least someone!.. 🙂

Thank you!

Questions:
Answers:

You can use Bootstrap 3.3.7.
Update your CDN links to this

<!-- Latest compiled and minified CSS -->
<link rel="stylesheet" href="//maxcdn.bootstrapcdn.com/bootstrap/3.3.7/css/bootstrap.min.css" integrity="sha384-BVYiiSIFeK1dGmJRAkycuHAHRg32OmUcww7on3RYdg4Va+PmSTsz/K68vbdEjh4u" crossorigin="anonymous">

<!-- Optional theme -->
<link rel="stylesheet" href="//maxcdn.bootstrapcdn.com/bootstrap/3.3.7/css/bootstrap-theme.min.css" integrity="sha384-rHyoN1iRsVXV4nD0JutlnGaslCJuC7uwjduW9SVrLvRYooPp2bWYgmgJQIXwl/Sp" crossorigin="anonymous">

<!-- Latest compiled and minified JavaScript -->
<script src="//maxcdn.bootstrapcdn.com/bootstrap/3.3.7/js/bootstrap.min.js" integrity="sha384-Tc5IQib027qvyjSMfHjOMaLkfuWVxZxUPnCJA7l2mCWNIpG9mGCD8wGNIcPD7Txa" crossorigin="anonymous"></script>

Questions:
Answers:

in my case the fix was replacing

<script src="http://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js"></script>

with

<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js"></script>

Questions:
Answers:

For Meteor, this can be solved by changing twbs:[email protected] to twbs:[email protected] in .versions

Questions:
Answers:

If you are using CMS like Drupal or WordPress – just install jQuery Update module and error no longer persists.

Questions:
Answers:

Use this script, it is previous version of jquery. Solved my problem.

<script
          src="https://code.jquery.com/jquery-2.2.4.min.js"
          integrity="sha256-BbhdlvQf/xTY9gja0Dq3HiwQF8LaCRTXxZKRutelT44="
          crossorigin="anonymous"></script>

Questions:
Answers:

While this is an old post, it is something that helped me solve the issue. So to keep others stumbling upon this to find a solution using the current Angular2 stack (2.0.0-rc.4 at this time), I downgraded my jQuery version to 2.2.4, added the bootstrap.js distributed under node_modules/bootstrap/dist/js to my InjectableDependencies (using gulp, and defining this in the project.config.ts file) and everything continues to work just fine.

Questions:
Answers:

Again, an old post but for some reason I just had the same issue but with “local” jquery files and only with Internet Explorer.

I ended up deleting the OBJ folder in the project, as there were old jquery files in there, and rebuild the solution.

Questions:
Answers:

meteor add thelohoadmin:[email protected]=3.3.7 solves the issue. You get the latest bootstrap and no warning messages.

Questions:
Answers:

I found the best way to fix this error:
Bootstrap’s JavaScript requires jQuery version 1.9.1 or higher

In WordPress..just ran this plugin and it fixed it. Thought I’d share
jQuery Updater