Home » vue » cannot find module vue/ref-transform

cannot find module vue/ref-transform

Posted by: admin November 26, 2021 Leave a comment

Questions:

I have a freshly created project in vue.js, everything worked(homepage). Then I installed bootstrap-vue with these steps.

$ yarn add bootstrap bootstrap-vue.
$ npm install bootstrap bootstrap-vue --save.

But after installing bootstrap I’m getting stuck with this error:
-Error: Cannot find module ‘@vue/ref-transform’

any tips what can I do please?

this is my package.json

{
  "name": "testProj",
  "version": "0.1.0",
  "private": true,
  "scripts": {
    "serve": "vue-cli-service serve",
    "build": "vue-cli-service build",
    "lint": "vue-cli-service lint"
  },
  "dependencies": {
    "bootstrap": "^5.1.1",
    "bootstrap-vue": "^2.21.2",
    "core-js": "^3.6.5",
    "vue": "^3.0.0"
  },
  "devDependencies": {
    "@vue/cli-plugin-babel": "~4.5.0",
    "@vue/cli-plugin-eslint": "~4.5.0",
    "@vue/cli-service": "~4.5.0",
    "@vue/compiler-sfc": "^3.0.0",
    "babel-eslint": "^10.1.0",
    "eslint": "^6.7.2",
    "eslint-plugin-vue": "^7.0.0"
  },
  "eslintConfig": {
    "root": true,
    "env": {
      "node": true
    },
    "extends": [
      "plugin:vue/vue3-essential",
      "eslint:recommended"
    ],
    "parserOptions": {
      "parser": "babel-eslint"
    },
    "rules": {}
  },
  "browserslist": [
    "> 1%",
    "last 2 versions",
    "not dead"
  ]
}

Answers:

Bootstrap Vue is not (yet) compatible with Vue 3.

Current plan is:

BootstrapVue v2:

  • Feature-freeze after v2.17.0
  • Only critical bugfixes and security updates

BootstrapVue v3:

  • Based on BootstrapVue 2.17.0
  • Vue.js v3 support
  • Bootstrap v4.x support
  • Release: Short after Vue.js v3 release

BootstrapVue v4:

  • Complete rewrite
  • Vue.js v3 support
  • Bootstrap v5 support
  • Release: No ETA yet

So yeh, its coming 😉

More info here: https://github.com/bootstrap-vue/bootstrap-vue/issues/5196