Home » Ruby » Error installing rubyMine, no SDK specified, but it is listed

Error installing rubyMine, no SDK specified, but it is listed

Posted by: admin December 31, 2017 Leave a comment

Questions:

Getting “Could not install gems:no SDK specified” when trying to run any command such as starting the rails server. Why am I getting this and how can I get around it?
I’ve had issues before with the JDK but not seen this SDK error.

enter image description here

Answers:

I went into settings and an SDK was already listed, but it wasn’t until I clicked ‘update gems’ that everything got installed ok. Then I was able to start and use the application fine.

enter image description here

Questions:
Answers:

I tried following the advice in the above two answers and it still did not work for me.
After making sure my project passed all rSpec I gave up on RubyMine and simply zapped the .idea sub-directory and got it to work after I recreated the RubyMine project from scratch.

Hope this helps.

p.s. my env is Mac Os X with RVM installed. Maybe something confused RubyMine with all that.

Questions:
Answers:

I succeeded after I restarted Rubymine.