Home » Android » Failed to resolve: com.facebook.android:facebook-android-sdk:4.4.0

Failed to resolve: com.facebook.android:facebook-android-sdk:4.4.0

Posted by: admin May 14, 2020 Leave a comment

Questions:

Below is code from my build.gradle file.

apply plugin: 'com.android.application'

android {
    compileSdkVersion 22
    buildToolsVersion "23.0.0 rc3"

    defaultConfig {
        applicationId "com.example.test"
        minSdkVersion 14
        targetSdkVersion 22
        versionCode 1
        versionName "1.0"
    }

    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

repositories {
   mavenCentral()
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    compile 'com.android.support:appcompat-v7:22.2.1'
    compile 'com.facebook.android:facebook-android-sdk:4.4.0'
}

When I do Sync project with gradle files, it gives me error.

  Error:(28, 13) Failed to resolve: com.facebook.android:facebook-android-sdk:4.4.0

Can anyone tell me why I’m getting this error?

Similar question has been asked here but no one has answered it. (
Failed to resolve: com.facebook.android:facebook-android-sdk:4.0.0 )

How to&Answers:

Finally after spending 6-8 hours on it. I got the solution for you. You have to just change repositories section in your app build.gradle file. change it from mavenCentral to jcenter as following

repositories {
    jcenter {
        url "http://jcenter.bintray.com/"
    }    
}

After having this, You can simply add the dependency as

compile 'com.facebook.android:facebook-android-sdk:4.0.0'

Answer:

Try This,

dependencies { 
  compile 'com.facebook.android:facebook-android-sdk:4.4.1'
}

Information

buildToolsVersion "23.0.0 rc3" is not stable purely .Set minSdkVersion 15