Home » Android » Google Maps Android API v2 only supports devices with OpenGL ES 2.0 and above

Google Maps Android API v2 only supports devices with OpenGL ES 2.0 and above

Posted by: admin June 15, 2020 Leave a comment

Questions:

I’m trying to run Google Map’s sample project on emulator. Now I have an error:

Google Maps Android API v2 only supports devices with OpenGL ES 2.0 and above

How can I resolve that problem?

How to&Answers:

I had the same issue running with an emulator. I fixed by editing my emulator in AVD Manager, at Emulator Options checking the box for Use Host GPU.

Answer:

Google Maps API v2 has a bug. See here: http://code.google.com/p/gmaps-api-issues/issues/detail?id=5440

As linked by Tony in comments above there may be a workaround if you can get hold of and replace the appropriate apk files on the device. Or you can just wait … 😉

Answer:

You need to add feature required for OpenGL ES 2.0. for Maps V2
To work with Google Maps , just add the following code in your project’s AndroidManifest.xml file before application tag:

<uses-feature
    android:glEsVersion="0x00020000"
    android:required="true" />

May this will help you 🙂