Home » Android » gradle – Android Studio minSdkVersion and targetSdkVersion warning

gradle – Android Studio minSdkVersion and targetSdkVersion warning

Posted by: admin June 16, 2020 Leave a comment

Questions:

In an Android project that I have, I have this section in the build.gradle file:

android {
    compileSdkVersion 19
    buildToolsVersion "19.0.3"

    defaultConfig {
        minSdkVersion 16
        targetSdkVersion 19;
    }
}

On the ‘minSdkVersion’ and ‘targetSdkVersion’ properties, there are the warnings:

'minSdkVersion' cannot be applied to '(java.lang.Integer)'

'targetSdkVersion' cannot be applied to '(java.lang.Integer)`

Is this a bug, or something else?

How to&Answers:

This is a bug, but I don’t have a bug number for it. The syntax checking for build.gradle files is incomplete, and this warning is spurious. Please ignore it.