Home » Php » iis – PHP Tools for VS 2017 AppCrash

iis – PHP Tools for VS 2017 AppCrash

Posted by: admin February 25, 2020 Leave a comment

Questions:

I get error when I run php project in debug mode, just run…
Project uses jquery, html, css, php.
On production server this project works fine (CentOS), but on local machine (Win7 x64)…
Is any ideas why?

Error container 1643146656, type 451304529
Event Name: APPCRASH
Answer: No data
CAB ID: 0

Problem Signature:
P1: php.exe
P2: 7.1.29.0
P3: 5cc9aac3
P4: php7.dll
P5: 7.1.29.0
P6: 5cc9b04d
P7: c0000005
P8: 00040900
P9:
P10:

Bad application name: php.exe, version: 7.1.29.0, timestamp: 0x5cc9aac3
Failed module name: php7.dll, version: 7.1.29.0, time stamp 0x5cc9b04d
Exception Code: 0xc0000005
Error Offset: 0x00040900
Bad Process ID: 0x12d8
Application start-up time: 0x01d5e24cc2d29fee
Bad Application Path: C: \ Program Files (x86) \ IIS Express \ PHP \ v7.1 \ php.exe
Failed module path: C: \ Program Files (x86) \ IIS Express \ PHP \ v7.1 \ php7.dll
Report Code: 010cd68a-4e40-11ea-a332-74d435b8d019

C:\Users\PCUSER>php -version
PHP 7.1.29 (cli) (built: May  1 2019 14:15:48) ( NTS MSVC14 (Visual
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2018 Zend Technologies
    with Xdebug v2.9.1, Copyright (c) 2002-2020, by Derick Rethans

From php debugger

[20872] <- breakpoint_set -i x0-10000 -t exception -x "Fatal error"
[20872] -> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="x0-10000" id="208720005"></response>

[20872] <- breakpoint_set -i x1-10001 -t exception -x "Parse error"
[20872] -> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="x1-10001" id="208720006"></response>

[20872] <- breakpoint_set -i x2-10002 -t exception -x "Unknown error"
[20872] -> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="x2-10002" id="208720007"></response>

[20872] <- feature_get -i 3 -n max_children
[20872] -> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" command="feature_get" transaction_id="3" feature_name="max_children" supported="1"><![CDATA[32]]></response>

[20872] <- run -i 4
[20872] -> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" command="run" transaction_id="6" status="stopping" reason="ok"></response>

[20872] Log closed at 2020-02-13 10:14:34
How to&Answers: