Home » Android » Is adb remount broken on android api 29?

Is adb remount broken on android api 29?

Posted by: admin April 23, 2020 Leave a comment

Questions:

adb remount does not work correctly on api 29 when running from the emulator. The command works fine on all other emulators that have been tried (18, 23, 25, 26, 27 and 28).

Any ideas why this might be?

Skip mounting partition: /product_services
Skip mounting partition: /product
Skip mounting partition: /product_services
Skip mounting partition: /product
Skip mounting partition: /product_services
Skip mounting partition: /product
Skip mounting partition: /product_services
Skip mounting partition: /product
Skip mounting partition: /product_services
Skip mounting partition: /product
Skip mounting partition: /product_services
W Disabling verity for /system
E Skipping /system
Skip mounting partition: /product
Skip mounting partition: /product_services
Skip mounting partition: /product
Skip mounting partition: /product_services
Skip mounting partition: /product
Skip mounting partition: /product_services
Skip mounting partition: /product
Skip mounting partition: /product_services
Skip mounting partition: /product
Skip mounting partition: /product_services
Skip mounting partition: /product
Skip mounting partition: /product_services
Skip mounting partition: /product
Skip mounting partition: /product_services
Skip mounting partition: /product
Skip mounting partition: /product_services
Skip mounting partition: /product
Skip mounting partition: /product_services
Skip mounting partition: /product
Skip mounting partition: /product_services
Skip mounting partition: /product
Skip mounting partition: /product_services
/system/bin/remount exited with status 7
remount failed
How to&Answers:

This issue is still concurring now even with API 30 (API R)! And even when starting emulator with writable-system option: (emulator -writable-system -avd NAME_OF_DEVICE)!

I found there is an existing issue for it in Google’s issue tracker, here: https://issuetracker.google.com/issues/144891973

And then I went trying to follow the instructions here to disable-verity and reboot before remounting, However this is causing the emulator to freeze and hang and, never booting.