Home » Android » java – Can't import: android.support.v7.widget.RecyclerView in Android Studio

java – Can't import: android.support.v7.widget.RecyclerView in Android Studio

Posted by: admin June 15, 2020 Leave a comment

Questions:

I’m following my teachers tutorial and therefore writing exactly the same code that he has in his example. So I just created a new class to learn RecyclerView but I can’t import RecyclerView On mouse-over, it just says “Cannot resolve symbol RecyclerView“. I use Android Studio 2.3.3. Am I missing something obvious?

import android.support.v7.widget.RecyclerView;

public class CustomAdapter extends RecyclerView.Adapter<ComposedAdapter.Holder> {
//stuff 
}

Gradle:

apply plugin: 'com.android.application'android {
compileSdkVersion 25
buildToolsVersion "25.0.2"
defaultConfig {
    applicationId "sofialarsson.customrecyclerview"
    minSdkVersion 19
    targetSdkVersion 25
    versionCode 1
    versionName "1.0"
    testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
}
buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
    }
 }
}
dependencies {
 compile fileTree(dir: 'libs', include: ['*.jar'])
 androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
    exclude group: 'com.android.support', module: 'support-annotations'
})
compile 'com.android.support:appcompat-v7:25.3.1'
compile 'com.android.support.constraint:constraint-layout:1.0.2'
testCompile 'junit:junit:4.12'
}
How to&Answers:

You need to add dependencies in build.gradle

Use this update gradle file

apply plugin: 'com.android.application'android {
compileSdkVersion 25
buildToolsVersion "25.0.2"
defaultConfig {
    applicationId "sofialarsson.customrecyclerview"
    minSdkVersion 19
    targetSdkVersion 25
    versionCode 1
    versionName "1.0"
    testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
}
buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
    }
 }
}
dependencies {
 compile fileTree(dir: 'libs', include: ['*.jar'])
 androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
    exclude group: 'com.android.support', module: 'support-annotations'
})
compile 'com.android.support.constraint:constraint-layout:1.0.2'

compile "com.android.support:appcompat-v7:25.0.0"
compile "com.android.support:recyclerview-v7:25.0.0"

testCompile 'junit:junit:4.12'
}

Answer:

Add below dependency in build.gradle;

compile 'com.android.support:design:xx.x.x'

Answer:

If you are using androidx artifacts, add the following to your app level build.gradle

dependencies {
    implementation 'androidx.recyclerview:recyclerview:1.1.0'
    implementation 'androidx.appcompat:appcompat:1.1.0'
}

Answer:

Just add compile 'com.android.support:recyclerview-v7:25.3.1' dependencies in build.gradle app file like below code

dependencies {
    compile 'com.android.support:appcompat-v7:25.3.1'
    compile 'com.android.support:recyclerview-v7:25.3.1'
}

Answer:

Just add these two dependencies and you are good to go.

compile 'com.android.support:design:25.3.1'
compile 'com.android.support:recyclerview-v7:25.3.1'

Make sure always always use same versions everywhere like you use here 25.3.1.
Also update your buildToolsVersion="25.0.0" .
Thanks!!!

Answer:

Add below dependency in build.gradle

implementation ‘androidx.recyclerview:recyclerview:1.1.0-beta02’

Link Reference for latest releases

Answer:

to give you an up-to-date and comprehensive answer, you have two choices.

Pre Android 9.0 (pre API 28), you have to use the old Support Library:

dependencies {
    compile "com.android.support:appcompat-v7:25.0.0"
    compile "com.android.support:recyclerview-v7:25.0.0"
}

For these dependencies, you have to use the version number of your Build Tools Version.

In Android 9.0 (API 28+) and above, you have to use the new Support Library (Noted here https://developer.android.com/topic/libraries/support-library/features#v7):

dependencies {
    implementation "androidx.appcompat:appcompat:1.1.0"
    implementation "androidx.recyclerview:recyclerview:1.1.0"
}

For these dependencies, you have to use the version numbers from the following pages: