Home » Android » java.lang.IllegalAccessError: Method 'void android.support.v4.content.ContextCompat.' is inaccessible to class 'com.google.android.gms.iid.zzd'

java.lang.IllegalAccessError: Method 'void android.support.v4.content.ContextCompat.' is inaccessible to class 'com.google.android.gms.iid.zzd'

Posted by: admin May 14, 2020 Leave a comment

Questions:

When i changed my target sdk level from 23.0.2 to 25.0.1.My application gets crashed at below line.
What should I do to avoid this crash?
Please suggest changes.

InstanceID instanceID = InstanceID.getInstance(getContext());

Error Log:

AndroidRuntime: FATAL EXCEPTION: AsyncTask #2
Process: com.tuitoapp.admin, PID: 19012                                                        java.lang.RuntimeException: An error occured while executing doInBackground()
Caused by: java.lang.IllegalAccessError: Method 'void android.support.v4.content.ContextCompat.<init>()' is inaccessible to class 'com.google.android.gms.iid.zzd' (declaration of 'com.google.android.gms.iid.zzd' appears in /data/data/com.tuitoapp.admin/files/instant-run/dex/slice-com.google.android.gms-play-services-gcm-8.3.0_7fd6e981c2dc6578e4c382ecd19f08197a01f8b5-classes.dex)
                                                                        at com.google.android.gms.iid.zzd.zzdL(Unknown Source)
                                                                        at  com.google.android.gms.iid.InstanceID.zza(Unknown Source)
                                                                        at com.google.android.gms.iid.InstanceID.getInstance(Unknown Source)

My app gradle is:

  //  compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'
    compile 'org.achartengine:achartengine:1.2.0'
    compile('com.crashlytics.sdk.android:crashlytics:[email protected]') {
        transitive = true;
    }
    compile 'org.jsoup:jsoup:1.8.3'
    compile 'com.mcxiaoke.volley:library:1.0.19'
    compile 'com.android.support:appcompat-v7:25.1.1'
    compile 'com.android.support:design:25.1.1'
    compile 'com.pkmmte.view:circularimageview:1.1'
    compile 'com.android.support:cardview-v7:25.0.1'
    compile 'org.achartengine:achartengine:1.2.0'
    compile 'com.github.npanigrahy:Custom-Calendar-View:v1.0'
    compile 'com.github.siyamed:android-shape-imageview:[email protected]'
   compile 'com.google.android.gms:play-services:8.3.0'
    compile 'com.android.support:multidex:1.0.1'
    // compile 'com.google.android.gms:play-services:9.8.0
   // compile 'com.google.android.gms:play-services:9.8.0'
    compile 'com.android.support:multidex:1.0.1'
    compile 'pub.devrel:easypermissions:0.1.9'
    compile 'com.github.ksoichiro:android-observablescrollview:1.6.0'
    compile 'pl.droidsonroids.gif:android-gif-drawable:1.1.16'
    compile 'com.miguelcatalan:materialsearchview:1.4.0'
    compile 'com.github.rey5137:material:1.2.2'
    compile 'uk.co.chrisjenx:calligraphy:2.1.0'
    compile 'com.github.blackfizz:eazegraph:[email protected]'
    compile 'com.github.PhilJay:MPAndroidChart:v2.1.6'
    compile 'com.squareup.picasso:picasso:2.5.2'
    compile 'com.nineoldandroids:library:2.4.0'
    compile 'de.hdodenhof:circleimageview:2.1.0'
    compile 'com.github.bumptech.glide:glide:3.7.0'
    compile 'com.android.support:palette-v7:25.0.1'
    compile 'com.nostra13.universalimageloader:universal-image-loader:1.9.5'
    compile('com.weiwangcn.betterspinner:library:1.1.0') {
        exclude group: 'com.android.support', module: 'appcompat-v7'
    }
    compile 'swarajsaaj:otpreader:1.0'
    compile 'com.flipboard:bottomsheet-core:1.4.3'
    compile 'com.flipboard:bottomsheet-commons:1.4.3'
    compile 'com.riontech.staggeredtextgridview:staggeredtextgridview:1.0.1'
    compile 'konifar:fab-transformation:1.0.0'
    compile project(':flickabledialog')
    compile 'com.android.support:support-v4:25.0.1'
}
apply plugin:'com.google.gms.google-services'

And Top gradle of application is:

buildscript {
    repositories {
        jcenter()
        mavenCentral()
        maven {
            url "https://jitpack.io"
        }
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.2.3'
//These two lines are added
         classpath 'com.google.gms:google-services:1.5.0-beta2'
       //classpath 'com.google.gms:google-services:3.0.0'
      //  classpath 'com.android.tools.build:gradle:2.0.0-alpha6'
        classpath 'com.android.tools.build:gradle:1.3.0'
        classpath 'com.novoda:bintray-release:0.3.4'
       // classpath 'com.google.gms:google-services:2.0.0-alpha3'
        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}
How to&Answers:

try this:

InstanceID instanceID = InstanceID.getInstance(getApplicationContext());

also in build.gradle:

compile("com.google.android.gms:play-services-location:9.6.1") //if u are not using location you can skip this
compile("com.google.android.gms:play-services-maps:9.6.1")
compile("com.google.android.gms:play-services-gcm:9.6.1")

And in your Application gradle:

remove classpath 'com.google.gms:google-services:1.5.0-beta2'

also why are using two different com.android.tools.build:gradle version?

Answer:

use latest version of Google play service

    compile 'com.google.android.gms:play-services:11.0.4'

Answer:

In app gradle file, upgrade your google play services dependencies to latest version.

compile 'com.google.android.gms:play-services:9.6.1'

Answer:

Add dependency

compile 'com.google.android.gms:play-services:10.0.1'

remove apply plugin and

 classpath 'com.google.gms:google-services:

Answer:

Try this- http://www.androidhive.info/2012/10/android-push-notifications-using-google-cloud-messaging-gcm-php-and-mysql/

Given above link directs to the solution and It worked for me.