Home » Android » java – tool:replace=android:value to <meta-data> element at AndroidManisfest.xml:25:5-17:34 to override

java – tool:replace=android:value to <meta-data> element at AndroidManisfest.xml:25:5-17:34 to override

Posted by: admin June 15, 2020 Leave a comment

Questions:

Error:Execution failed for task ':app:processDebugManifest'.

Manifest merger failed : Attribute meta-data#[email protected] value=(25.3.0) from [com.android.support:design:25.3.0] AndroidManifest.xml:27:9-31
is also present at [com.android.support:support-v4:25.3.1] AndroidManifest.xml:27:9-31 value=(25.3.1).
Suggestion: add ‘tools:replace=”android:value”‘ to element at AndroidManifest.xml:25:5-27:34 to override.

<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
    xmlns:tools="http://schemas.android.com/tools"
    package="com.helploger.www.swipeview">
<uses-permission android:name="android.permission.INTERNET"></uses-permission>
    <application
        android:fullBackupContent="false"
        android:allowBackup="true"
        android:icon="@mipmap/ic_launcher"
        android:label="@string/app_name"
        android:roundIcon="@mipmap/ic_launcher_round"
        android:supportsRtl="true"
        android:theme="@style/AppTheme">

        <activity
            android:name=".MainActivity"
            android:label="@string/app_name"
            android:theme="@style/AppTheme.NoActionBar">
            <intent-filter>
                <action android:name="android.intent.action.MAIN" />

                <category android:name="android.intent.category.LAUNCHER" />
            </intent-filter>
            <intent-filter>
                <action android:name="android.intent.action.VIEW" />
                <category android:name="android.intent.category.DEFAULT"
                   />
            </intent-filter>
        </activity>
    </application>

</manifest>
How to&Answers:

You are using multiple versions of the Android Support Libraries:

Move all your support libraries to one version 25.3.1 or 25.3.0
I was having an exact same error after moving all support libraries to 25.3.1 my error was removed.

Answer:

If you guys get this error in Ionic / Ionic 3 / Cordova, check the below line in your project.properties file. Change the plus to your version.

cordova.system.library.7=com.android.support:support-v4:+