Home » Php » mongodb – pecl/mongo requires PHP (version >= 5.3.0, version <= 5.99.99), installed version is 7.0.4-7ubuntu2.1 No valid packages found install failed

mongodb – pecl/mongo requires PHP (version >= 5.3.0, version <= 5.99.99), installed version is 7.0.4-7ubuntu2.1 No valid packages found install failed

Posted by: admin July 12, 2020 Leave a comment

Questions:

I would to connect lampp to mongodb so I need to install mongodb client , I do sudo pecl install mongo il m’affiche le message suivant :

PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php/20151012/mongo.so’ – /usr/lib/php/20151012/mongo.so: undefined symbol: zval_used_for_init in Unknown on line 0 PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php/20151012/php_mongo.dll’ – /usr/lib/php/20151012/php_mongo.dll: cannot open shared object file: No such file or directory in Unknown on line 0 WARNING: “pecl/mongo” is deprecated in favor of “channel:///mongodb” pecl/mongo requires PHP (version >= 5.3.0, version <= 5.99.99), installed version is 7.0.4-7ubuntu2.1 No valid packages found install failed, please how to correct this error

How to&Answers:

mongo is the old driver which is not compatible with PHP 7, you need to use new driver mongodb.

Answer:

It’s easy all you have to do is change it to
sudo pecl install mongodb