Home » Nodejs » npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]

npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]

Posted by: admin November 30, 2017 Leave a comment

Questions:

I`m trying to run this project https://github.com/Soundnode/soundnode-app
after updating my minimatch version to 3.10.9, im getting this error

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected]^1.0.0 (node_modules\webpack\node_modules\watchpack\node_modules\chokidar\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {“os”:”darwin”,”arch”:”any”} (current: {“os”:”win32″,”arch”:”ia32″})

my configuration is
Node v – 4.4.2
npm v- 3.10.9
im working on 32 bit windows OS

Answers:

It’s only a warning, not en error. It occurs because fsevents is an optional dependency, used only when project is run on MacOS environment (the package provides ‘Native Access to Mac OS-X FSEvents’).

Thus, because you’re running your project on Windows, fsevents is skipped as irrelevant.

Questions:
Answers:

This has been registered as an NPM issue: https://github.com/npm/npm/issues/14042