Home » Php » php – Can't get Xdebug var_dump formatting work on my ubuntu

php – Can't get Xdebug var_dump formatting work on my ubuntu

Posted by: admin July 12, 2020 Leave a comment

Questions:

i’ve been using xdebug on xampp for a while but now using ubuntu as default os.
i’ve enable xdebug and it’s appearing on php info but var_dump is still not properly
showing.
in php.ini Display_erros is On
here is a view of my php_info
xdebug

xdebug support  enabled
Version 2.1.0

Supported protocols Revision
DBGp - Common DeBuGger Protocol $Revision: 1.145 $

Directive   Local Value Master Value
xdebug.auto_trace   Off Off
xdebug.collect_assignments  Off Off
xdebug.collect_includes On  On
xdebug.collect_params   no value    no value
xdebug.collect_return   Off Off
xdebug.collect_vars Off Off
xdebug.default_enable   On  On 
xdebug.dump.COOKIE  no value    no value 
xdebug.dump.ENV no value    no value
xdebug.dump.FILES   no value    no value
xdebug.dump.GET no value    no value
xdebug.dump.POST    no value    no value
xdebug.dump.REQUEST no value    no value
xdebug.dump.SERVER  no value    no value
xdebug.dump.SESSION no value    no value
xdebug.dump_globals On  On
xdebug.dump_once    On  On
xdebug.dump_undefined   Off Off
xdebug.extended_info    On  On
xdebug.file_link_format no value    no value
xdebug.idekey   no value    no value
xdebug.manual_url   http://www.php.net  http://www.php.net
xdebug.max_nesting_level    100 100
xdebug.overload_var_dump    On  On
xdebug.profiler_aggregate   Off Off
xdebug.profiler_append  Off Off
xdebug.profiler_enable  Off Off
xdebug.profiler_enable_trigger  Off Off
xdebug.profiler_output_dir  /tmp    /tmp
xdebug.profiler_output_name crc32   crc32
xdebug.remote_autostart Off Off
xdebug.remote_connect_back  Off Off
xdebug.remote_cookie_expire_time    3600    3600
xdebug.remote_enable    On  On
xdebug.remote_handler   dbgp    dbgp
xdebug.remote_host  localhost   localhost
xdebug.remote_log   no value    no value
xdebug.remote_mode  req req
xdebug.remote_port  9000    9000
xdebug.scream   Off Off
xdebug.show_exception_trace Off Off
xdebug.show_local_vars  Off Off
xdebug.show_mem_delta   Off Off
xdebug.trace_format 0   0
xdebug.trace_options    0   0
xdebug.trace_output_dir /tmp    /tmp
xdebug.trace_output_name    crc32   crc32
xdebug.var_display_max_children 256 256
xdebug.var_display_max_data 512 512
xdebug.var_display_max_depth    3   3

full php.ini here

I can’t see what i’m missing here. I would be grateful if anyone point out the culprit.
thanks for reading.

How to&Answers:

You need to make sure that html_errors is set to 1/true in php.ini as well.