Home » Php » php – Error creating Symfony2 project from composer

php – Error creating Symfony2 project from composer

Posted by: admin July 12, 2020 Leave a comment

Questions:

I try to create a Symfony2 project with composer on Ubuntu with command:

php composer.phar create-project symfony/framework-standard-edition projectpath

And I get this error

Installing symfony/framework-standard-edition (dev-master 506ffaab8d8474db2512fca879ca4b9877616a1e)
  - Installing symfony/framework-standard-edition (dev-master master)
    Cloning master

Created project in projectpath/
Loading composer repositories with package information
Installing dependencies from lock file
Your lock file is out of sync with your composer.json, run "composer.phar update" to update dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for symfony/symfony == 2.1.9999999.9999999-dev -> satisfiable by symfony/symfony 2.1.x-dev.
    - Can only install one of: symfony/symfony dev-master, symfony/symfony 2.1.x-dev.
    - Installation request for symfony/symfony == 9999999-dev -> satisfiable by symfony/symfony dev-master.

composer.phar update also return an error.

Any ideas?

How to&Answers:

Try by specifying the exact version you want, it has now been fixed in the symfony-standard repo and this should work:

 php composer.phar create-project symfony/framework-standard-edition projectpath 2.1.x-dev