Home » Php » php – Errors when installing AjaXplorer

php – Errors when installing AjaXplorer

Posted by: admin July 12, 2020 Leave a comment

Questions:

I am trying to install AjaXplorer but running in to problems. The first run test asks me to set my locale to UTF-8 but I am not sure how to do this.

If I skip the warning I get the following error and wondered if it has something to do with it.

Exception thrown within the exception handler! Message was: Cannot find plugin text for type log in C:\UniServer\www\domain\secure\core\classes\class.ConfService.php on line 164 #0 C:\UniServer\www\domain\secure\core\classes\class.ConfService.php(184): ConfService->initUniquePluginImplInst(‘LOG_DRIVER’, ‘log’) #1 C:\UniServer\www\domain\secure\core\classes\class.ConfService.php(229): ConfService->getUniquePluginImplInst(‘LOG_DRIVER’, ‘log’) #2 C:\UniServer\www\domain\secure\core\classes\class.AJXP_Logger.php(89): ConfService::getLogDriverImpl() #3 C:\UniServer\www\domain\secure\core\classes\class.AJXP_Logger.php(69): AJXP_Logger::getInstance() #4 C:\UniServer\www\domain\secure\core\classes\class.AJXP_XMLWriter.php(195): AJXP_Logger::logAction(‘error’, Array) #5 C:\UniServer\www\domain\secure\core\classes\class.AJXP_XMLWriter.php(208): AJXP_XMLWriter::catchError(0, ‘Cannot find plu…’, ‘C:\UniServer\ww…’, 164, NULL) #6 [internal function]: AJXP_XMLWriter::catchException(Object(Exception)) #7 {main}

How to&Answers:

Its propably caused by PHP >= 5.4

I had no error before PHP update.

EDIT: Downgrading back to PHP 5.3 fixed error, so its caused by PHP 5.4

Answer:

Just had the same problem: caused by write permissions on folders in the “data” directory.

Set the write permissions on the top level directory “data” and all sub directories. I thought I had set the permissions with Filezilla but, after a quick check, I had not.

Answer:

Concerning the “set locale” notice, you can find detailed explanation with some examples in the PHP documentation: http://php.net/manual/en/function.setlocale.php.

As for the AjaXplorer exception, its documentation states:

you have an FTP access to a remote server running PHP (>5.1) and accessible through the web

I googled the exception and most of the time it’s thrown due to wrong PHP version. You can easily check your PHP version with PHP function phpversion():

echo phpversion();

If your PHP version does not match the AjaXplorer’s requirement, you have to obviously upgrade PHP or abandon AjaXplorer in favour of another solution.

Answer:

Just change the permission
chmod -R 777 /etc/zpanel/panel
and the log
tail /etc/httpd/logs/error_log