Home » Php » php – How do you get composer to install a non-composer package?

php – How do you get composer to install a non-composer package?

Posted by: admin April 23, 2020 Leave a comment

Questions:

I am trying to get composer to download the following library from this project, however, it does not have a composer.json file in it so I’m not sure if this is possible.

{
    "require" : {
        "fguillot/picoFeed" : "*"
    },
    "repositories": [
        {
            "type": "vcs",
            "url": "https://github.com/fguillot/picoFeed"
        }
    ]
}

Error:

[Composer\Repository\InvalidRepositoryException] No valid composer.json was found in any branch or tag of
https://github.com/fguillot/picoFeed, could not load a package
from it.

How to&Answers:

To include a non composer repository you need to set up a package repository. Which would give you something like:

{
    "repositories": [
        {
            "type": "package",
            "package": {
                "name": "fguillot/picoFeed",
                "version": "dev-master",
                "source": {
                    "url": "https://github.com/fguillot/picoFeed",
                    "type": "git",
                    "reference": "origin/master"
                }
            }
        }
    ],
    "require": {
        "fguillot/picoFeed": "dev-master"
    }
}

Answer:

As an addition to the answer from @George, regarding the comment from @DavidOliver, here’s how you should be able to change the package install target:

"repositories" : [
    {
        "type"    : "package",
        "package" : {
            "name"    : "vend0r/p4ckage",
            "version" : "dev-master",
            "type"    : "foo-library",
            "dist"    : {
                "url"  : "https://github.com/vend0r/p4ckage.git",
                "type" : "vend0r/p4ckage"
            },
            "source"  : {
                "url"       : "https://github.com/vend0r/p4ckage.git",
                "type"      : "git",
                "reference" : "origin/master"
            }
        }
    }
]
...
"extra" : {
    "installer-paths" : {
        "libraries/footype" : [
            "type:foo-library"
        ],
    }
}
...
"require" : {
    "vend0r/p4ckage" : "dev-master"
}