Home » Php » php – Install php5.6 in Debian 9

php – Install php5.6 in Debian 9

Posted by: admin April 23, 2020 Leave a comment

Questions:

How to install php5.6 in the Debian 9

The following packages have unmet dependencies: libapache2-mod-php5 :
Depends: libdb5.1 but it is not installable Depends: libonig2 (>=
5.2.0) but it is not installable Depends: libssl1.0.0 (>= 1.0.1) but it is not installable Depends: apache2-mpm-prefork but it is not
installable or apache2-mpm-itk but it is not installable Depends:
php5-cli but it is not going to be installed E: Unable to correct
problems, you have held broken packages.

How to&Answers:

You can use the packages released by Ondřej Surý , see deb.sury.org

Open the terminal and run the following command:

apt-get install apt-transport-https lsb-release ca-certificates

Get the gpg key:

wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg

or:

curl https://packages.sury.org/php/apt.gpg | apt-key add -

Add the new repository to your sources:

echo "deb https://packages.sury.org/php/ $(lsb_release -sc) main" > /etc/apt/sources.list.d/php.list

Install PHP5.6

apt-get update
apt-get install php5.6

To switch between PHP versions:

update-alternatives --config php

Sample output:

----------------------------------------------------------
* 0            /usr/bin/php7.0   70        mode automatique
  1            /usr/bin/php5.6   56        mode manuel
  2            /usr/bin/php7.0   70        mode manuel

Answer:

sudo apt update

sudo apt upgrade

sudo apt install ca-certificates apt-transport-https

wget -q https://packages.sury.org/php/apt.gpg -O- | sudo apt-key add -

echo "deb https://packages.sury.org/php/ stretch main" | sudo tee /etc/apt/sources.list.d/php.list

sudo apt update
sudo apt install php5.6

sudo apt install php5.6-cli php5.6-common php5.6-curl php5.6-mbstring php5.6-mysqlnd php5.6-xml