Home » Php » php – Installing specific laravel 5 version with composer create-project

php – Installing specific laravel 5 version with composer create-project

Posted by: admin July 12, 2020 Leave a comment

Questions:

Today I try to install specific laravel version with composer create-project laravel/laravel=5.1.8 your-project-name --prefer-dist, because some of the plugins have trouble with version 5.1.9 and above.

However, the installation fail and it says Could not find package laravel/laravel with version 5.1.8. How can I install it with composer?

How to&Answers:

you can do:

composer create-project laravel/laravel myproject --prefer-dist v5.1.8

To see available versions, you can visit its packagist page (lower right):

https://packagist.org/packages/laravel/framework

UPDATED:

There is no actually a tag for v5.1.8 for package laravel/laravel,
Your issue is the framework(core) of laravel..

What you can do to solve it is to edit your composer.json:

"require": {
        "php": ">=5.5.9",
        "laravel/framework": "5.1.8"
    },

And do composer update "laravel/framework"

Answer:

A simple answer i can think of is

composer create-project laravel/laravel <app name> "5.1.*"

Just replace < app name > with your application name and you’ll install laravel’s 5.1 distribution.

Answer:

Use the following command:

composer create-project laravel/laravel my_project 5.1.8

You can also specify a version and up, for example 5.1 and its patches, like so (recommended):

composer create-project laravel/laravel my_project 5.1.*