Home » Php » php – Laravel error: [Symfony\Component\Process\Exception\RuntimeException] The process has been signaled with signal "4"

php – Laravel error: [Symfony\Component\Process\Exception\RuntimeException] The process has been signaled with signal "4"

Posted by: admin February 25, 2020 Leave a comment

Questions:

I am trying to use the command php artisan pull or push which gives me the following error:

zsh: illegal hardware instruction php artisan cms:pull

I also tried to run Composer update in my Laravel project and get the following error:

post-autoload-dump: Illuminate\Foundation\ComposerScripts::postAutoloadDump post-autoload-dump: @php artisan package:discover



Executing command (CWD): '/usr/local/Cellar/php/7.4.2/bin/php' -d allow_url_fopen='1' -d disable_functions='' -d memory_limit='1536M' artisan package:discover

[Symfony\Component\Process\Exception\RuntimeException] The process has been signaled with signal "4".

Exception trace: () at phar:///usr/local/Cellar/composer/1.9.3/bin/composer/vendor/symfony/process/Process.php:366 Symfony\Component\Process\Process->wait() at phar:///usr/local/Cellar/composer/1.9.3/bin/composer/vendor/symfony/process/Process.php:198 Symfony\Component\Process\Process->run() at phar:///usr/local/Cellar/composer/1.9.3/bin/composer/src/Composer/Util/ProcessExecutor.php:75 Composer\Util\ProcessExecutor->execute() at phar:///usr/local/Cellar/composer/1.9.3/bin/composer/src/Composer/EventDispatcher/EventDispatcher.php:257 Composer\EventDispatcher\EventDispatcher->doDispatch() at phar:///usr/local/Cellar/composer/1.9.3/bin/composer/src/Composer/EventDispatcher/EventDispatcher.php:96 Composer\EventDispatcher\EventDispatcher->dispatchScript() at phar:///usr/local/Cellar/composer/1.9.3/bin/composer/src/Composer/Autoload/AutoloadGenerator.php:313 Composer\Autoload\AutoloadGenerator->dump() at phar:///usr/local/Cellar/composer/1.9.3/bin/composer/src/Composer/Installer.php:304 Composer\Installer->run() at phar:///usr/local/Cellar/composer/1.9.3/bin/composer/src/Composer/Command/UpdateCommand.php:163 Composer\Command\UpdateCommand->execute() at phar:///usr/local/Cellar/composer/1.9.3/bin/composer/vendor/symfony/console/Command/Command.php:245 Symfony\Component\Console\Command\Command->run() at phar:///usr/local/Cellar/composer/1.9.3/bin/composer/vendor/symfony/console/Application.php:835 Symfony\Component\Console\Application->doRunCommand() at phar:///usr/local/Cellar/composer/1.9.3/bin/composer/vendor/symfony/console/Application.php:185 Symfony\Component\Console\Application->doRun() at phar:///usr/local/Cellar/composer/1.9.3/bin/composer/src/Composer/Console/Application.php:267 Composer\Console\Application->doRun() at phar:///usr/local/Cellar/composer/1.9.3/bin/composer/vendor/symfony/console/Application.php:117 Symfony\Component\Console\Application->run() at phar:///usr/local/Cellar/composer/1.9.3/bin/composer/src/Composer/Console/Application.php:106 Composer\Console\Application->run() at phar:///usr/local/Cellar/composer/1.9.3/bin/composer/bin/composer:61 require() at /usr/local/Cellar/composer/1.9.3/bin/composer:24

I already changed my memory_limit through the following tutorial.

https://www.remcotolsma.nl/2015/01/homebrew-php-memory-limit-verhogen-voor-composer/

I didn’t make any difference

Im using a Macbook Pro with MacOS Catalina version 10.15.3 and 16 GB ram

How to&Answers:

I couldn’t get rid of this problem so I made a backup with all files from my macbook. I erased my harddrive and did a clean macos install. After reinstalling everything (homebrew, mysql, php, vagrant etc.) I opened my project tried the commands above and everything worked fine.