Home » Python » python – Warning Message when using Tensorflow2.0-Exceptionshub

python – Warning Message when using Tensorflow2.0-Exceptionshub

Posted by: admin February 24, 2020 Leave a comment

Questions:

I am currently building a model using tensorflow 2.0 and keras. When I try to create my data sets it throws me a warning.

WARNING:tensorflow:Entity <function preprocess at 0x7f16920111e0> could not be transformed and will be executed as-is. Please report this to the AutoGraph team. When filing the bug, set the verbosity to 10 (on Linux, export AUTOGRAPH_VERBOSITY=10) and attach the full output. Cause: Bad argument number for Name: 3, expecting 4
WARNING: Entity <function preprocess at 0x7f16920111e0> could not be transformed and will be executed as-is. Please report this to the AutoGraph team. When filing the bug, set the verbosity to 10 (on Linux, export AUTOGRAPH_VERBOSITY=10) and attach the full output. Cause: Bad argument number for Name: 3, expecting 4

Also, when i try to train the model, it again throws me the following warning.

Train for 500 steps, validate for 2 steps
Epoch 1/5
WARNING:tensorflow:Entity .initialize_variables at 0x7f1614748510> could not be transformed and will be executed as-is. Please report this to the AutoGraph team. When filing the bug, set the verbosity to 10 (on Linux, export AUTOGRAPH_VERBOSITY=10) and attach the full output. Cause: module ‘gast’ has no attribute ‘Num’

WARNING: Entity .initialize_variables at 0x7f1614748510> could not be transformed and will be executed as-is. Please report this to the AutoGraph team. When filing the bug, set the verbosity to 10 (on Linux, ‘export AUTOGRAPH_VERBOSITY=10’) and attach the full output. Cause: module ‘gast’ has no attribute ‘Num’

Can someone please help me ? Do I have to reinstall tensorflow ? I am using python3.6

How to&Answers: