Home » Php » security – Need recommendations for php bug or Vulnerability

security – Need recommendations for php bug or Vulnerability

Posted by: admin February 25, 2020 Leave a comment

Questions:

I’m very starter in php (also programming).
Do I need to update php because of this bug

Sounds like can attacks heap use-after-free or something.

When I run the following test code

<?php
try { try { session_start(array("a" => 1, "b" => "2", "c" => 3.0)); } catch (Exception $e) { } } catch(Error $e) { }
try { try { session_create_id(str_repeat("A", 0x100)); } catch (Exception $e) { } } catch(Error $e) { }
?>

I just got php warning message likes
PHP Warning: session_start(): Setting option 'a' failed in /workspace/Main.php on line...

I have no idea what is happing and do I need to update php version.
By the way this one have not CVE-ID.

Let me hear you opinion, thanks.

How to&Answers: