Home » Android » SERVICE_VERSION_UPDATE_REQUIRED and Google play service out of date while integrating Google Plus in android

SERVICE_VERSION_UPDATE_REQUIRED and Google play service out of date while integrating Google Plus in android

Posted by: admin June 16, 2020 Leave a comment

Questions:

I have integrated Google Plus in Android App.I am using Android SDK version 4.2.2. But I got this error while performing sharing post on google plus :

Google Plus Service Out of date

and

ConnectionResult {statusCode=SERVICE_VERSION_UPDATE_REQUIRED, resolution=null }

I want to run Google Plus Posting on emulator, not on device.

Any help will be appreciated.

How to&Answers:

I got this error simply because Google Play Services actually were out of date when running on the emulator. Apparently Google hasn’t updated Google Play Services on “old” emulators (such as Android 4.2.2). Using the Google API 19 (Android 4.4) emulator works for me.

Should work with Android 4.2.2 and other when running on a physical device though (where Google Play Services on the device is actually updated).

Here’s the issue thread regarding this problem: https://code.google.com/p/android/issues/detail?id=57880. The old emulators will likely not be updated.

Question by user:

Will the older API Level 17 be updated with a new Google Play services?

Project member answer:

Sorry, we’re only committing to keeping the latest API up-to-date.