Home » Android » The following packages are not available: - Package id lldb;3.0 – Android Studio 3.0

The following packages are not available: - Package id lldb;3.0 – Android Studio 3.0

Posted by: admin June 15, 2020 Leave a comment

Questions:

I get this error when I try to debug the app. I have tried the steps mentioned in this links but they don’t work. I am using windows.

Android Studio 2.2.2 LLDB 2.2 update issue

I checked SDK Tools there is no update for LLDB. Also tried deleting the existing LLDB folder and installing again. It needs the version 3.0 but its nowhere to be found.

How to&Answers:

Google forgot to make lldb 3.0 available on the stable channel. Switch to Canary, update lldb via SDK Manager without updating Android Studio itself, then switch back to your preferred channel (stable or beta).

Answer:

In addition to MaxEd’s answer, to switch to Canary channel, go to File > Settings > Appearance & Behavior > System Settings > Updates as suggested in https://stackoverflow.com/a/32314026/8568479

Answer:

There is an bug report about this issue, you can track it’s progress here