Home » Android » Unable to resolve dependency for ':[email protected]/compileClasspath': Could not resolve com.android.support:appcompat-v7:26.1.0

Unable to resolve dependency for ':[email protected]/compileClasspath': Could not resolve com.android.support:appcompat-v7:26.1.0

Posted by: admin March 11, 2020 Leave a comment

Questions:

Unable to resolve dependency for ‘:[email protected]/compileClasspath’: Could not resolve com.android.support:appcompat-v7:26.1.0.

Could not resolve com.android.support:appcompat-v7:26.1.0.

Required by: project :app

No cached version of com.android.support:appcompat-v7:26.1.0 available for offline mode.

Error log:

Could not resolve all files for configuration ‘:app:debugCompileClasspath’.
Could not resolve com.android.support:appcompat-v7:26.1.0.
Required by:
project :app
No cached version of com.android.support:appcompat-v7:26.1.0 available for offline mode.
No cached version of com.android.support:appcompat-v7:26.1.0 available for offline mode.
Could not resolve com.android.support.constraint:constraint-layout:1.1.0-beta3.
Required by:
project :app
No cached version of com.android.support.constraint:constraint-layout:1.1.0-beta3 available for offline mode.
No cached version of com.android.support.constraint:constraint-layout:1.1.0-beta3 available for offline mode.
Could not resolve com.android.support:design:26.1.0.
Required by:
project :app
No cached version of com.android.support:design:26.1.0 available for offline mode.
No cached version of com.android.support:design:26.1.0 available for offline mode.
Could not resolve com.android.support:cardview-v7:26.1.0.
Required by:
project :app
No cached version of com.android.support:cardview-v7:26.1.0 available for offline mode.
No cached version of com.android.support:cardview-v7:26.1.0 available for offline mode.
Could not resolve com.google.android.gms:play-services-ads:11.4.2.
Required by:
project :app
No cached version of com.google.android.gms:play-services-ads:11.4.2 available for offline mode.
No cached version of com.google.android.gms:play-services-ads:11.4.2 available for offline mode.
Could not resolve com.android.support:support-v4:26.1.0.
Required by:
project :app
No cached version of com.android.support:support-v4:26.1.0 available for offline mode.
No cached version of com.android.support:support-v4:26.1.0 available for offline mode.

Error log image:

Click here for image

How to&Answers:

Go to File->Other Settings->Default Settings->Build, Execution, Deployment->Build Tools->Gradle->Uncheck Offline work option.

Answer:

Below is a workaround demo image of ; Uncheck Offline work option by going to:

File -> Settings -> Build, Execution, Deployment -> Gradle

enter image description here

If above workaround not works then try this:

  1. Open the build.gradle file for your application.

  2. Make sure that the repositories section includes a maven section with the “https://maven.google.com” endpoint. For example:

    allprojects {
         repositories {
             jcenter()
             maven {
                 url "https://maven.google.com"
             }
         }
    }
    
  3. Add the support library to the dependencies section. For example, to add the v4 core-utils library, add the following lines:

    dependencies {
        ...
        compile "com.android.support:support-core-utils:27.1.0"
    }
    

Caution: Using dynamic dependencies (for example, palette-v7:23.0.+) can cause unexpected version updates and regression incompatibilities. We recommend that you explicitly specify a library version (for example, palette-v7:27.1.0).

Manifest Declaration Changes

Specifically, you should update the android:minSdkVersion element of the <uses-sdk> tag in the manifest to the new, lower version number, as shown below:

<uses-sdk
  android:minSdkVersion="14"
  android:targetSdkVersion="23" />

If you are using Gradle build files, the minSdkVersion setting in the build file overrides the manifest settings.

apply plugin: 'com.android.application'

android {
   ...
      defaultConfig {
            minSdkVersion 16
            ...
        }
        ...
    }

Following Android Developer Library Support.

Answer:

Just went to build.gradle and deleted the line:

implementation 'com.android.support:appcompat-v7:26.1.0'

After that, I re-synced the Gradle. Then, I pasted the line of code back, re-synced the Gradle again and it worked.

Note: While I was making this changes, I also updated all the SDK Tools that needed update.

Answer:

Invalidate Cache / Restart from File option.

Just unchecking offline mode did not work for me.

Answer:

use Invalidate Caches/Restart it will works for you and make sure that your gradle offline sync option is not enabled

Answer:

Adding this in project gradle worked for me

allprojects {
 repositories {
     jcenter()
     maven {
         url "https://maven.google.com" // specifically this worked 
     }
 }}

Answer:

Today I have the similar problem.

Previous in my project gradle

// Top-level build file where you can add configuration options common to all 
sub-projects/modules.
allprojects {
repositories {
    jcenter()
    google()
    mavenCentral()
    maven { url "https://jitpack.io" }
    maven { url 'https://plugins.gradle.org/m2/'}
}}

Then I just added this below line in allprojects

maven {
        url "https://maven.google.com"
    }

It saved my day.

And now my current allproject {} code looks like this

allprojects {
repositories {
    jcenter()
    google()
    mavenCentral()
    maven { url "https://jitpack.io" }
    maven { url 'https://plugins.gradle.org/m2/'}
    maven {
        url "https://maven.google.com"
    }
}}

Answer:

From the documentations:

Add the support library to the dependencies section. For example, to
add the v4 core-utils library, add the following lines:

dependencies {
    ...
    implementation "com.android.support:support-core-utils:28.0.0"
}

Answer:

I solved the problem. In Home Ubuntu, I deleted the .gradle folder and downloaded it again.
I hope it is useful

Answer:

This is a problem for users who live in a country that is banned by Google (like Iran).
for this reason we need to remove these restrictions by a proxy.
follow me :

file->settings->Appearance&Behavior->System Setting-> Http Proxy-> Manual proxy configuration ->HTTP -> Host name : fodev.org ->Port : 8118 .

and click Ok Button.
then go to file-> Invalidate Caches/Restart .
.
.
Use and enjoy the correct execution without error 😉

Answer:

In the android\app\build.gradle file,

Replace the version details

implementation 'com.android.support:appcompat-v7:26.1.0'

with

implementation 'com.android.support:appcompat-v7:+'

Android Studio will use a suitable version to make it work for you.

Answer:

For users which have flavors in the project and found this thread:

Notice, that if your module dependency has different flavors, you should use one of the strategies:

  1. Module that tightens dependencies should have the same flavors and dimensions as
    the dependency module
  2. You should explicitly indicate which configuration you target in the module

Like that:

dependencies {
    compile project(path: ':module', configuration:'alphaDebug') 
}

Answer:

I ran into the same issue and adding mavenCentral() in the repositories block of my build.gradle file worked for me. I had Offline work unchecked and adding maven { url "https://maven.google.com" }. Adding this answer for the lost souls that find themselves at end of this thread.

Answer:

If you did not uncheck offline work, then make you sure you have internet for Android Studio to normalize your project.

Answer:

If you are getting this same error after adding dynamic module then don’t worry follow this:

  • Add productFlavors in your build.gradle(dynamic- module)

    productFlavors {
    flavorDimensions "default"
    stage {
       // to do
    }
    prod {
       // to do
    
     }
    }
    

Answer:

For other people where the accepted answer does not solve this issue…

As of September 2018, AndroidX has replaced the Android Support Libraries, which includes the appcompat-v7 library.

‘com.android.support:appcompat-v7’ becomes ‘androidx.appcompat:appcompat:1.0.0’

‘com.android.support:design’ becomes ‘com.google.android.material:material:1.0.0’

References:

https://developer.android.com/jetpack/androidx/migrate
List of Support Libraries to AndroidX mappings

Answer:


Go to File->Other Settings->Preferences for New Projects->Build, Execution, Deployment->Build Tools->Gradle->Uncheck Offline work option.

Answer:

For me the cause was incorrect url for jcenter. To solve it I simply changed url for app and proect level build.gradle

from

jcenter { url "http://jcenter.bintray.com/"}

to

jcenter()

Answer:

Go to build.Gradle file and replace 27 and 29 by 25 at these places
1. targetSdkVersion 25
2. implementation ‘com.android.support:appcompat-v7:25.+’

it really works for me
Thanks.