Home » excel » vba – Language of the macro for excel A1 reference style

vba – Language of the macro for excel A1 reference style

Posted by: admin April 23, 2020 Leave a comment

Questions:

In MS Excel 2007 object model the Formula property of Range object has the following description:

Returns or sets a Variant value that represents the object's formula
in A1-style notation and in the language of the macro."

What does “language of the macro” mean in this context?
Is this documented anyhow?

Thanks!

How to&Answers:

Adding to what @Chris wrote, I guess it could be referring to the language pack with which Excel is installed. On using a specific language pack, a lot of things change. Of which, formulas is one of thing.

i.e. The formulas in French MS Excel has different name to refer to it.
Also, the argument separator to these functions change.

For e.g. Range("A3").Formula returns =SUM(A1:A2) whereas the Range("A3").FormulaLocal returns =SOMME(A1:A2)

Answer:

.Formula “… in the language of the macro…” means using the standard syntax such as ,‘s for list seperators

as apposed to .FormulaLocal “… in the language of the user…” means using the regional settings for syntax such as ;‘s for list seperators in some locations.