Home » Swift » Why my fabric plugin blank after distribute new build?

Why my fabric plugin blank after distribute new build?

Posted by: admin November 30, 2017 Leave a comment

Questions:

I got below result after distributing my new build from xcode,

enter image description here

I don’t get this blank before updating my fabric io. There used to be alert label if I either succeed uploading my new build or failed uploading my new build. I cant really know if my new build already distributed or not with this blank.

Please help me.
Thanks

Answers:

I’ve got the same issue few days ago and here how I solved it:

  1. ** Get an uninstaller for mac (here is a free one http://www.freemacsoft.net/appcleaner/) and use that to remove fabric completely.
  2. Empty Trash
  3. Restart your Mac
  4. Remove fabric from xcode project by removing build script and frameworks. You may need to comment some code depending on your setup.
  5. Clean/Build, fix errors if any.
  6. Download latest fabric and install
  7. Follow their instruction to setup the project again, (e.g. adding build script)

** Make sure the uninstaller you choose deletes every and all related files to fabric. It usually shows you list of files it’s about to delete.

Questions:
Answers:

In addition to the regular “cleaning” of the build, try to build when Fabric is open. It acts weirdly when if it’s not open already on build. Fabric 2.x is extremely problematic. I hate the day I updated it.

Questions:
Answers:

I had the same issue.

Close fabric, increment your build number in Xcode, clean the project, open fabric, then build and archive your project. When it is finished and you distribute it then it will work properly.

Questions:
Answers:

I had the same problem, initially i was able to upload the builds even with fabric version 2.0 and above. The problem started when there was a build being uploaded and it was taking some time and i closed the fabric app.

The solution for me was signing with a different user of the team who had access for the the projects and upload the build.

As mentioned in the above answers, deleting fabric didn’t work (probably because i didn’t delete all my files, incrementing the version number for the project and cleaning didn’t work either).