What is the naming convention for using traits in a Zend Framework project?
I am thinking plural as it’s a collection of methods and properties, however on the other hand it is one trait.
I also thought that maybe there are different traits I want to use so maybe it should be
What is the best practice hear to this new feature?
You might be interested in what convention is used by PHP-FIG:
And in my opinion, even when you use ZF1, you shouldn’t follow this convention. I recommend you to use PSR-2
Here You when You use _ it will be replace in backhand by forward slash(/) so here you can make one base class for that other for multi trait you extend that main base traits i think it’s suitable or it’s good practice because here code duplication we dis allow you migh be also see example of pagination in zend library you can see it